WebPagetest Forums
Seeing very high ttfb and dowload times for Cloudfront content - Printable Version

+- WebPagetest Forums (https://www.webpagetest.org/forums)
+-- Forum: Web Performance (/forumdisplay.php?fid=3)
+--- Forum: Discuss Test Results (/forumdisplay.php?fid=4)
+--- Thread: Seeing very high ttfb and dowload times for Cloudfront content (/showthread.php?tid=12291)



Seeing very high ttfb and dowload times for Cloudfront content - ari - 05-27-2013 01:25 AM

I have been running tests from multiple locations all over the USA using chrome and I'm seeing very high download times for images coming from cloudfront only when testing using WPT when I used another testing services the image download and TTFB seem to be much much faster.

WPT examples:
http://www.webpagetest.org/result/130526_YP_H2S/1/details/
http://www.webpagetest.org/result/130526_TA_FBE/1/details/
http://www.webpagetest.org/result/130526_A3_EK7/1/details/

other service:
http://tools.pingdom.com/fpt/#!/iNtuC/http://www.abesmarket.com/


RE: Seeing very high ttfb and dowload times for Cloudfront content - pmeenan - 06-01-2013 06:25 AM

Looks like you have saturated the 5Mbps connection that you were testing on on WebPagetest (in the advanced settings you can configure the allocated bandwidth). That is also likely why the latency was higher - most tools just test using a full backbone connection.

If you look at the bandwidth chart at the bottom of the WPT waterfalls you can see that it's pretty much pegged for the whole time. 3.7MB is a pretty huge page. Are those retina images (they appear to be larger than they show on the page)? You'll get a better user experience if you can break up the loading of the images and only load the ones that are above the fold with the page itself and lazy-load the others (after onload maybe). That way the main images will not be competing for bandwidth with images that are not immediately visible.

You're also not really helping things by sharding them across 3 domains, that just puts even more bits on the wire at a time and you're probably running into a bunch of congestion (Will Chan had a great blog post on it here: https://insouciant.org/tech/network-congestion-and-web-browsing/


RE: Seeing very high ttfb and dowload times for Cloudfront content - ari - 06-03-2013 09:32 PM

Thanks Patrick,

I have shrunk the dimensions of the images we are loading to fall closer to the max dimensions we need on the page (page is responsive)

I also removed the media1 and media2 domains.

The problem now is that there seems to always be one or two images that are taking an extraordinary amount of time to load

http://www.webpagetest.org/result/130603_FX_J6G/

thanks for your help,

-Ari


RE: Seeing very high ttfb and dowload times for Cloudfront content - pmeenan - 06-06-2013 07:12 AM

FWIW, looks like the image issue may have been transient but the globalconvert code on your page is trying to make a request from a server that isn't accepting connections: http://www.webpagetest.org/result/130605_9P_1H4F/

If you don't absolutely need it, I recommend removing it or reaching out to them to see what's going on.