WebPagetest Forums
Chrome repeat run is beginning with JS instead of Document - Printable Version

+- WebPagetest Forums (https://www.webpagetest.org/forums)
+-- Forum: Web Performance (/forumdisplay.php?fid=3)
+--- Forum: Optimization Discussions (/forumdisplay.php?fid=5)
+--- Thread: Chrome repeat run is beginning with JS instead of Document (/showthread.php?tid=12936)



Chrome repeat run is beginning with JS instead of Document - geedew - 04-24-2014 05:14 AM

I've been running tests quite a bit and I can't explain why my SSL pages are getting odd results on the second run.

http://www.webpagetest.org/result/140423_JR_W1K/1/details/cached/

It's only if Chrome too. Firefox for instance runs from the Document as first byte.

Any idea where blame may lay on why it's running oddly?


RE: Chrome repeat run is beginning with JS instead of Document - pmeenan - 04-29-2014 04:23 AM

Only thing that comes to mind is an instrumentation oddity with Chrome.

I rely on Chrome's dev tools for SSL traffic and Chrome has an interesting behavior where it requests the base page before it creates the renderer for the page but the timing data is tied to the renderer so anything that happens before the renderer starts up may not be visible. There are a bunch of things in place to minimize the impact but every now and then you see strange things like that.

For IE and Firefox I can get the SSL measurements directly from the networking stack so the measurements tend to be more complete.


RE: Chrome repeat run is beginning with JS instead of Document - Anton Chigurh - 04-29-2014 04:30 AM

Code:
Leverage browser caching of static assets: 76/100

FAILED - (No max-age or expires) - https://sproutsocial.com/signup/start/premium_v3
FAILED - (No max-age or expires) - https://munchkin.marketo.net/munchkin.js
WARNING - (1.0 hours) - https://tracker.marinsm.com/tracker/async/c0otnfhoc0.js
WARNING - (12.0 hours) - https://stats.g.doubleclick.net/dc.js



RE: Chrome repeat run is beginning with JS instead of Document - pmeenan - 04-29-2014 05:00 AM

@Anton - the problem is that the base HTML page isn't showing up in the waterfall even though it has a max-age of 0. That and the missing SSL negotiation point to the requests being made but not logged. Unfortunately getting SSL data out of Chrome is a lot more difficult than the other browsers.


RE: Chrome repeat run is beginning with JS instead of Document - Anton Chigurh - 04-29-2014 06:26 AM

(04-29-2014 05:00 AM)pmeenan Wrote:  @Anton - the problem is that the base HTML page isn't showing up in the waterfall even though it has a max-age of 0. That and the missing SSL negotiation point to the requests being made but not logged. Unfortunately getting SSL data out of Chrome is a lot more difficult than the other browsers.
Right but, he is talking about second run. First run is fine. The only things the second run should be picking up is things that weren't cached the first time. Am I wrong about that?