WebPagetest Forums
Sending request to url - Printable Version

+- WebPagetest Forums (https://www.webpagetest.org/forums)
+-- Forum: Web Performance (/forumdisplay.php?fid=3)
+--- Forum: Discuss Test Results (/forumdisplay.php?fid=4)
+--- Thread: Sending request to url (/showthread.php?tid=13495)



Sending request to url - Speedo - 01-19-2015 08:54 PM

hello,

i am trying to get json response for my website but when i am trying to send request to the website through the eclipse, its not connecting to the webpagetest server and keep on trying to connect but always fails.


RE: Sending request to url - pmeenan - 01-21-2015 02:28 AM

Sorry, I don't understand. What request, what website and what does eclipse have to do with it? Are you trying to use the API?

Since the API is all URL driven you can debug any issues just by loading API URLs in a browser and seeing what they do. If it works in a browser but not in code then there's a code problem with either generating the URL or making the request.


RE: Sending request to url - Speedo - 01-21-2015 08:51 PM

thanks..one more doubt that is there any command or method to generate api key without actually coming to your website and giving email manually ??


RE: Sending request to url - pmeenan - 01-22-2015 01:36 AM

No. At least on the public instance because that would be abusing what it is intended for (either automating scraping a bunch of keys or running a different service on top of the public instance).

For a private instance you can manage the keys (if any) however you'd like.