WebPagetest Forums
How Start Render is taken with video capture is disabled before testing - Printable Version

+- WebPagetest Forums (https://www.webpagetest.org/forums)
+-- Forum: WebPagetest (/forumdisplay.php?fid=7)
+--- Forum: General Discussion (/forumdisplay.php?fid=25)
+--- Thread: How Start Render is taken with video capture is disabled before testing (/showthread.php?tid=14043)



How Start Render is taken with video capture is disabled before testing - lsr1991 - 11-06-2015 10:50 PM

As Patrick described in this post before:

Quote:Start render is measured by capturing video of the page load and looking at each frame for the first time the browser displays something other than a blank page. It can only be measured in a lab and is generally the most accurate measurement for it.

in my opinion, when I disable the video capture before testing, the start render cannot be taken from the video frames. But it still appears in the test result. How does the test runner get its value? Any feedbacks are appreciated.


RE: How Start Render is taken with video capture is disabled before testing - pmeenan - 11-13-2015 02:17 AM

There was a change to the desktop agents ~6 months ago so they always capture video locally and only upload it with the results if video capture is enabled. That way they can still calculate all of the video metrics. It's generally safest to still enable video capture so you can validate results in the filmstrip and it's still needed for the mobile agents.


RE: How Start Render is taken with video capture is disabled before testing - lsr1991 - 01-05-2016 01:05 AM

thx very much ~Smile