WebPagetest Forums
Totally Inaccurate Image Optimization Reporting?? - Printable Version

+- WebPagetest Forums (https://www.webpagetest.org/forums)
+-- Forum: Web Performance (/forumdisplay.php?fid=3)
+--- Forum: Optimization Discussions (/forumdisplay.php?fid=5)
+--- Thread: Totally Inaccurate Image Optimization Reporting?? (/showthread.php?tid=14529)



Totally Inaccurate Image Optimization Reporting?? - AndrewNYC - 09-29-2016 05:26 AM

I have been testing my site with webpagetest.org for some time now, and I also use GTMetrix, pingdom and pagespeed. WBT is reporting an F for image optimization with image weights far larger than they actually are. I confirmed this by checking the images one by one and they are all at the size WBT recommends that they should be optimized at. I use photoshop to optimize every image up front, and then Wordpress resized the images down from 1000px to 500px automatically for this particular image size. None of the other sites are reporting the images as being un-optimized so this is a fairly big error on the part of WBT.org. Other than that this is my favorite testing site. Cheers...


RE: Totally Inaccurate Image Optimization Reporting?? - pmeenan - 09-30-2016 01:07 AM

Do you have a link to the test result? Hard to say without having access to the raw test but I've never seen the image optimization check be incorrect.


RE: Totally Inaccurate Image Optimization Reporting?? - AndrewNYC - 10-01-2016 10:11 AM

Yes, here you are: https://www.webpagetest.org/result/161001_9F_c6a5023a43bcce62408f02591881c830/1/performance_optimization/#compress_images. The test is not accurate, the images have all been optimized Thanks


RE: Totally Inaccurate Image Optimization Reporting?? - pmeenan - 10-02-2016 12:34 AM

WPT is the only one of those tools that recompresses the images at quality level 85, the rest only check to see if the images are sized to the same size as displayed (in pixels) or MAYBE check to see if the metadata has been removed.

It looks like the images were saved at a very high quality level which is why WPT is flagging them. It looks like your wordpress resizer is saving them at quality level 100.

Here is an example: https://www.webpagetest.org/jpeginfo/jpeginfo.php?url=http%3A%2F%2Fimg.andrewprokos.com%2FBBRIDGE-WTC-GEHRY-VT-PANO-2014-2264-1000PX-347x500.jpg

It looks like you block embedding by referer so the images themselves don't show here but you can get to the analysis of any one of the images from here: https://www.webpagetest.org/pageimages.php?test=161001_9F_c6a5023a43bcce62408f02591881c830&run=1