WebPagetest Forums
Visual Progress Chart data export - Printable Version

+- WebPagetest Forums (https://www.webpagetest.org/forums)
+-- Forum: Web Performance (/forumdisplay.php?fid=3)
+--- Forum: Discuss Test Results (/forumdisplay.php?fid=4)
+--- Thread: Visual Progress Chart data export (/showthread.php?tid=13924)



Visual Progress Chart data export - chelvan - 09-13-2015 12:51 AM

Is there a way to export the visual progress chart data from a given run? I want to be able to get the data from that chart into a spreadsheet. I have been able to recreate a chart from a run by grabbing the XML data from the test, and using the data from the time and visually complete columns (columns RT and RV). But I am not sure if this is the correct data.

Also in a related question, I haven't been able to get the XML from some tests. As I understand, you can get the XML from a test as follows:

http://www.webpagetest.org/xmlResult/[testID]/

But for some reason that doesn't seem to work with each test.


RE: Visual Progress Chart data export - andydavies - 09-14-2015 06:50 PM

If you pull the JSON response e.g. http://www.webpagetest.org/result/150911_8W_70fd03cac5fa3c6099b1e29f979eadf2/?f=json

You see a videoFrames array within each run's data, this is the same data that's plotted on that chart.


RE: Visual Progress Chart data export - pmeenan - 09-14-2015 10:16 PM

The XML data should also include the visual progress along with the frames: https://github.com/WPO-Foundation/webpagetest/blob/master/www/xmlResult.php#L314

Do you have an example where the XML was not available but the regular result was? It shouldn't be possible because they both use the same underlying data.


RE: Visual Progress Chart data export - chelvan - 09-15-2015 10:35 AM

(09-14-2015 10:16 PM)pmeenan Wrote:  The XML data should also include the visual progress along with the frames: https://github.com/WPO-Foundation/webpagetest/blob/master/www/xmlResult.php#L314

Do you have an example where the XML was not available but the regular result was? It shouldn't be possible because they both use the same underlying data.

Patrick - I thought I tried the URL yesterday and it gave a 404 error. Now it is ok - Although I admit I might have entered the wrong test ID - this URL works fine now. I will let you know though if I have any issues. Thanks


http://www.webpagetest.org/xmlResult/150912_8P_GVP/