WebPagetest Forums
Can't start browsers - Printable Version

+- WebPagetest Forums (https://www.webpagetest.org/forums)
+-- Forum: WebPagetest (/forumdisplay.php?fid=7)
+--- Forum: Private Instances (/forumdisplay.php?fid=12)
+--- Thread: Can't start browsers (/showthread.php?tid=14414)

Can't start browsers - Kevin Tierney - 07-26-2016 02:05 AM

The test agent and server are communicating, but when I start a test for Chrome or Firefox, the test times out saying it was waiting for the browser to start. Both browsers start from the command prompt window using the "exe" path value in wptdriver.ini with no "options" string. I've set WPTDIR to point to the directory containing the extension directory, although when I start Chrome from the command line using the "options", it reports the manifest file is unreadable or corrupt, and starting from the server gives the same time out error. Am I setting something incorrectly? Thanks.

P.S. The connection setting is "Native", to bypass traffic shaping, because dummynet and ipfw aren't installed.

RE: Can't start browsers - pmeenan - 07-26-2016 11:24 PM

Did you install the 32-bit versions of Chrome and Firefox (necessary even on a 64-bit system)?

What version of wptdriver is running? The server will list the version in the /getTesters.php page?

RE: Can't start browsers - Kevin Tierney - 07-27-2016 04:29 AM

I've re-installed the 32-bit versions of Chrome (52.0.2743.82 m) and Firefox (47.0.1, file ver 6018).
When I run a test, the task manager on the test agen shows "chrome.exe *32" and "firefox.exe *32".
getTesterrs.php doesn't show any version info on wptdriver, but I just downloaded update.zip and wptupdate.zip this morning. Their .ini files show versions: update - 386, wptupdate - 291.
Does WPT need an X-windows-like environment variable like "DISPLAY :0" to connect to the display?

When I load chrome from the command prompt, it says the manifest file is missing or corrupt. I'm not using %PROFILE% in the command.

Also, I have IE 11 configured in wptdriver.ini. When I run a test on this, it returns the message "Invalid Browser Selected IE 11". This version is on the test PC. Should I remove the IE init from wptdriver.ini and set urlBlast.exe as a task like wptdriver.exe, using urlBlast.ini to initialize?

RE: Can't start browsers - Kevin Tierney - 07-27-2016 10:11 PM

Due to security concerns, I didn't install dummynet and ipfw, so the TESTSIGNING variable hasn't been set in the boot record on the test agent PC. Would this prevent the browsers from starting? Thanks.

RE: Can't start browsers - pmeenan - 07-29-2016 04:18 AM

Make sure the locations.ini on the server is configured with "Connectivity=LAN" (or whatever string you want to use) so traffic shaping would be disabled.

RE: Can't start browsers - Kevin Tierney - 07-29-2016 05:52 AM

I changed the USERNAME environment variable from SYSTEM to my username, and that seemed to fix the problem with Firefox. No browser window appears, but I get a waterfall and the metrics. I was running this with a Native connection, so avoided traffic shaping. We altered the location.ini and wptdriver.ini file slightly. This causes IE 11 to be recognized as a valid browser, but it and Chrome time out. I added th "connectivity=LAN" line to location.ini, so the onlt Connection type showing in the Advanced pane is "LAN". Reran tests for all 3 browsers. Firefox OK, Chrome and IE 11 still time out waiting for startup. The Chrome log data showed the following error:

[4612:..... :ERROR:"child_process_launcher.cc(515)] Failed to launch child process

Is there possibly a problem with the versions of Chrome (52.0.2743.82 m) and IE 11 (11.0.9600.16428) being used?
Thanks for your help.

RE: Can't start browsers - pmeenan - 07-29-2016 10:05 PM

Is there any other software running that might be interfering? Since you're in a fairly restrictive requirement I'm wondering if you have EMET or McAffee or some similar A/V or restriction software that might be having issues with how the WPT agents inject their code into the browsers.

RE: Can't start browsers - Kevin Tierney - 07-29-2016 10:35 PM

I've tried running with the Symantec security app completely disabled. No difference. I am not able to turn off UAC. Would that make a difference? Perhaps our IT dept. is able to.
Also, does adding TESTSIGNING ON to the boot loader have any effect on wptdriver.exe's behavior? I didn't think I needed it because we have no use for traffic shaping. Thanks for your continuing help. There is someone else at the company that has set up WPT. We are trying some things, but not a lot of luck so far. If any progress, I will post.

RE: Can't start browsers - pmeenan - 07-29-2016 11:31 PM

The test signing doesn't matter for wptdriver and is only related to dummynet. UAC shouldn't matter as long as wptdriver is started with admin rights.

There's a good chance that "disabled" for the security app isn't the same as "uninstalled" and there may be a conflict with the code.

RE: Can't start browsers - Kevin Tierney - 07-30-2016 05:53 AM

Patrick, my colleague was able to get this up and running. We removed the wptdriver scheduled task and put a shortcut in my Startup folder. Now the browsers start up and run fine. Except IE 11. It starts OK, but on about:blank, not the test URL, and then reports that it timed out. All 3 browsers were tested on the same URL.